Introduction to ArcGIS Server and the Flex API

You will learn:

· To understand map services and applications
· How to create a map service definition and publish it to ArcGIS Server

· An overview of ArcGIS Server installation and configuration

· How to consume map services in desktop and web applications

· About the Adobe Flex API and the ESRI API for Flex
· To use the Viewer for Flex to quickly create web applications with Flex

· How to deploy web applications to a server

Getting Started

Log in to computer using credentials on the whiteboard (if not done for you already)
Download course material from: http://www.isws.illinois.edu/ftp/gis/download/agsflex/ 
The Paradigm: Services and Applications
Google Maps: Deconstructed
In 2005, Google Maps revolutionized web mapping with their AJAX implementation of “slippy” maps, meaning that users could pan around.  This allowed web maps to behave more like desktop GIS applications, and has now become the standard.
Open http://maps.google.com in a web browser.  You should see something similar to Figure 1.  The end user will see this as a single interface, but GIS professionals should recognize two major components of Google Maps: the map (tile) service, and the application.

Map service: Google Maps has rendered map tiles for the entire world at 20 scale levels.  As the user navigates the map, JavaScript is executed on the client (the web browser) that downloads the necessary tiles.  This action occurs asynchronously, meaning that the tile requests are not necessarily tied to a web page request.  Map tiles can then be loaded into the map window without requiring a full request of the entire web page.  This is a marked improvement over original map interfaces like older MapQuest, Yahoo!, and ArcIMS sites.
Application: The Google Maps application primarily consists of the user interface (UI) that allows for interaction with the map.  This includes the portions of the interface highlighted in red in Figure 1 (search box, basemap selector, navigation, scalebar), as well as the mouse navigation (scroll zoom in/out, pan).
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Figure 1: Google Maps interface, application area highlighted in red
The end user should never have to think in this paradigm – it should either seem like a packaged solution (web), or like adding a layer (desktop).

ArcGIS Server: Map Services
What if you want to display tiles other than the typical basemaps similar to the ones offered by Google Maps?  ESRI ArcGIS Server will allow you to do that.  In fact, they offer a web site where people share custom ArcGIS Server maps that you can use.

Browsing Shared Map Services

1. Navigate to http://www.arcgis.com/home/ and click on Gallery

2. Click on the Recent Population Change in USA.  This map service will open in a JavaScript API web application.

3. Zoom in to an area of interest, and keep zooming.  Notice how the granularity changes from state to county to census block group to census tract.

This is an example of a shared map service.  Think of the application as a means to control and interact with the map, and the map services as layers or building blocks in the map.

Creating Map Services
The map services from the previous step were authored in ArcMap and served via ArcGIS Server.  How can you create your own map services?  For this example, let’s assume we want to be able to show a map of ####
1. Start ArcMap with a new .mxd

2. Add in the USGSgages.shp file.

3. Symbolize the feature class as you wish.  For ArcGIS Server map services, ESRI recommends using the ESRI_Optimized symbol set, available under Style References.  These will render faster than other complex symbols and improve server responsiveness.
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4. From the Data Frame properties dialog, change the projection to Projected Coord Sys > World > Web Mercator (Auxiliary Sphere).  For more information about this projection, read http://help.arcgis.com/en/arcgisonline/content/index.html#//011q00000005000000.htm
5. Open the Map Service Publishing Toolbar 
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6. Click the first button to Analyze Map.  This will check for errors or suggest optimizations to improve the performance of this map as a map service.

Note: to reproject the underlying data to Web Mercator (Aux), use ArcToolbox > Data Management Tools > Projections and Transformations > Feature > Project
7. Click the second button to Preview the map as a map service.

8. If you are happy with the condition of your map, click the third button to Save a Map Service Definition.  These are very similar to .mxd files, but are optimized for publishing as map services.  The next version of ArcGIS Server, 10.1, will allow only .msd files to be published (no more support for publishing .mxd).

Publishing Map Services

Because of security limitations regarding your login accounts and our server, you will be unable to publish your .msd to a live ArcGIS Server.  However, we will demonstrate how to do this so you can see how to publish to your own ArcGIS Server.
There are two main ways to administer ArcGIS Server, and they both offer similar functionality:
· ArcCatalog: under GIS Servers, create a connection to Manage Services.  You will need to be on the same network and configure the server firewall (http://resources.arcgis.com/content/kbase?fa=articleShow&d=27798)

· Web interface: navigate to http://yourserverurl/arcgis/manager and log in as a user in the agsadmin group.
demonstration
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2. Click Publish a GIS Resource
3. Navigate to the .mxd or .msd to be published, then choose a service name and folder for publishing
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4. Click through the rest of the dialog (choosing defaults).  You should be able to see the map service listed with a preview.
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View Available Map Services
You can view available map services through the REST API by navigating to the URL of a known ArcGIS Server.

1. Navigate to http://services.arcgisonline.com/ArcGIS/rest/services/
2. Click on the link to the Demographics folder
3. Click on Demographics/USA_1990-2000_Population_Change
Here you can view the service description, layers, and other information.  You can also preview the layer by clicking View In: ArcGIS JavaScript (I prefer to right-click and Open In New Tab).
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ArcGIS Server: Setup and Security

Setting up your own ArcGIS Server will give you the most flexibility in creating and serving map services.
ArcGIS Server can be run in a Microsoft .NET environment on Windows (preferably Windows Server 2008), or in a Java environment on Windows, Linux (Red Hat Enterprise or SUSE), or Sun Solaris.  For the purpose of this course, we will assume a Microsoft .NET environment on Windows.

ArcGIS Server Installation

The installation guide for ArcGIS Server .NET is at http://help.arcgis.com/en/arcgisserver/10.0/install_guide/arcgis_server_net_install_guide/
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ArcGIS Server Security

ArcGIS Server will create three accounts and two groups when you install it.  The three accounts are
· ArcGISSOM: account for GIS Server Object Manager process
· ArcGISSOC: account for GIS Server Object Container process
· ArcGISWebServices: account that web services access the SOM with
The two user groups are

· agsadmin: ArcGIS Server administrators (publish/manage services)

· agsusers: ArcGIS Server users (access services)

Any ArcGIS Server setup will have exactly one SOM and one or more SOCs.  The SOM listens for incoming requests and has the SOCs render them.  The SOM and SOC can reside on the same server, but you can add more servers as SOCs if you need to scale your ability to serve maps.  The SOCs are the “worker bees” that render the map tiles to be served.
Securing individual services is too advanced for the scope of this course, but ArcGIS Server does allow you to do that.  Read the help documentation online for more information.
ArcGIS Server Planning

The architecture of your ArcGIS Server installation will be based on the implementation of your network environment and preferred workflow.

Single Server
The single server setup is the most simple and will require the least amount of forethought.  However, it is generally impractical, so you may want to consider other options. 
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Multiple Servers

What will most likely happen is that your configuration will be based loosely around the following roles: web server, ArcGIS Server, file server, and editing workstations.  This situation may look something like the following:


[image: image11]
Some notes about this type of setup:

· The most important part of this configuration is having the separate client/author workstation.  This is because most workflows will not involve loading up ArcMap on the server and creating .msd files connecting to local data.
· Although there is a slight performance hit and ArcMap will throw “informational warnings” about it, using UNC pathnames is the key to making this work.  These look like \\servername\sharename\folder instead of c:\gisdata\folder

· When rendering tiles, the ArcGISSOC is going to try and load all data from the .msd as it is stored.  That is why it is important to use UNC pathnames, and also to make sure that the ArcGISSOC has read access on the file server!
· You will need to create an ArcGISSOC user on each computer that hosts GIS files, and that user must have the same password as the one on the ArcGIS server.  ESRI does not recommend using domain accounts, although that may make this process easier.

ArcGIS Server: Desktop Applications

ArcGIS Server map services are natively supported in ArcGIS Explorer and ArcMap (both ESRI software products).  You can configure ArcGIS Server map services to be served at KML/KMZ, which allows for import into Google Earth as well.

For the next couple of exercises, we will be looking at map services related to the FIRMfinder project, which allows users to locate the Flood Insurance Rate Map panel number of their residence.
ArcGIS Explorer

ArcGIS Explorer is ESRI’s freely available lightweight GIS data viewer.  It is very similar in function and appearance to Google Earth, although it integrates better with ESRI products and offers some unique features.  For this exercise, we will add the FIRM Finder layer for a county into the Explorer map.
1. To start ArcGIS Explorer, open Start > All Programs > ArcGIS Explorer > ArcGIS Explorer.  You will probably see a notice about reduced color depth – this is because the program wants to reduce all graphical overhead in order to improve program performance. The program will start in 2D mode with a photography basemap.

2. To add an ArcGIS Server map service, click Add Content > GIS Services
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3. Enter http://gismaps.sws.uiuc.edu/ArcGIS/Services into the server address and click Next:
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4. Click on the FIRMFinder folder and choose a county map service of your choice.  ArcGIS Explorer will load this map service and zoom in to it.

Pan around and see how the map service functions.  Swap out basemaps if you want.  You may notice that the labeling is inconsistent.  This is because the service is set to dynamically label each polygon, and ArcGIS Server comes up with arbitrary boundaries on redrawing labels.  There are ways around this, but as you will see later in the course, ArcGIS Explorer is not the target application of this map service, and therefore is not a concern of meeting our business needs.

5. Close ArcGIS Explorer.

ArcMap

ArcMap is one of the flagship programs of ESRI’s ArcGIS Desktop suite.  It is used by GIS professionals around the world, and it too can consume web services.
1. Open ArcMap from Start > All Programs > ArcGIS > ArcMap 10

2. Open the ArcCatalog tab (should be on right) and navigate to GIS Servers
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3. Double click on Add ArcGIS Server

4. In the next window, choose to Use GIS Services

5. Enter the following the server URL of http://gismaps.sws.uiuc.edu/arcgis/services
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6. Click Finish
7. Navigate to the FIRMfinder folder, and choose a county to view by dragging it into the view pane

8. Add a basemap for reference

9. Use the Identify tool to see the attributes attached to the feature classes in the map service

ArcGIS Server: Web Applications
Often the most effective way to share your data is to share it through software that virtually all computers already have: a web browser.  ESRI offers several ways to create applications that consume ArcGIS services, and they fall into two major camps: the Web ADF (Application Developer Framework) and REST (Representational State Transfer) APIs.  The ADF comes in two flavors: .NET and Java.  We won’t focus on those in this course, because they require an advanced degree of programming knowledge and are fading in popularity as the REST APIs become more robust.
Web APIs: http://resources.arcgis.com/content/arcgisserver/web-apis
As of version 2.0, the REST APIs are supported on Firefox 3.5, Chrome 4, Internet Explorer 7 & 8, and Safari 3.  The Flash and Silverlight plugins are required for the Flex and Silverlight API, respectively.  There are three main flavors of REST API:

Javascript API

The JavaScript API is a popular API built on the Dojo Toolkit (http://dojotoolkit.org/).  The benefits of using a JavaScript API are that no plugins are required, and web applications should render on the iPhone platform (and possibly other mobile devices, if the browsers are compliant).  However, the downside is that JavaScript blockers and differences in browsers can cause inconsistent results among different platforms (although these concerns are relatively minor).  Several free JavaScript IDEs and utilities are available, such as Eclipse, Aptana, and the Firebug plugin for Mozilla Firefox.
Getting started: http://help.arcgis.com/en/webapi/javascript/arcgis/help/jshelp_start.htm 

ESRI has released two extensions based on the JSAPI – The ArcGIS Extension for the Google Maps API, and the ArcGIS Extension for Bing Maps.  Both of these allow you to publish a map service for consumption into a Google or Bing Maps web application.

Example: http://illinoisfloodmaps.org/
Flex API

The Flex API is another popular API that is built on the Adobe Flash platform.  Any browser with the ubiquitous Flash plugin installed (estimated at over 90% of installed browsers) should consistently render maps on the client side.  The drawback to using Flash is that iPhones and some other mobile devices do not have a Flash plugin available.  The Flex API is free to use and open source, but Adobe’s Flash Builder 4 is a commercial product.
Getting started: http://help.arcgis.com/en/webapi/flex/help/index.html
Silverlight API

The Silverlight API is built on the Microsoft Silverlight platform, which requires a plugin like Flash, but is not as widely deployed (some estimate around 60 to 70% of web-connected devices).  Development requires Visual Studio 2010 (Web Developer version), Microsoft Expression Blend, and the Silverlight Tools for VS2010 and plugin.
Getting started: http://help.arcgis.com/en/webapi/silverlight/help/index.html
Adobe Flex
What is Flex?
From http://www.adobe.com/products/flex/overview/: 
“Flex is a free, open source framework for building highly interactive, expressive web applications that deploy consistently on all major browsers, desktops, and operating systems.

Flex provides a modern, standards-based language and programming model that supports common design patterns. MXML, a declarative XML-based language, is used to describe UI layout and behaviors, and the object-oriented ActionScript® 3.0 programming language is used to create client logic. Flex also includes a rich component library with more than 100 proven, extensible UI components for creating rich Internet applications (RIAs), as well as an interactive Flex application debugger.”

Terminology
MXML – Tag-based language used to design and arrange the user interface of an application.  Examples include the buttons, labels, images in an application.

ActionScript – object-oriented language with the same syntax and semantics of JavaScript.  It is generally used for programming the behaviors of an application.  For instance, what happens when you click one of the buttons in the application or hover over an image.

FXG – Stands for Flash XML Graphics.  It provides a way to share graphics between other Adobe products like Illustrator or Photoshop.  You can create artwork in either of these programs and export them to FXG graphics and then reference them in your Flex application.  If we have time, I might go over an example of an FXG graphic that you might find useful in a mapping application.  For instance, a legend or a logo.  

Adobe Integrated Runtime or AIR is for building Flash applications for the desktop, independent of the operating system of the computer.

Application Programming Interface (API) serves as an interface between different software programs and facilitates their interaction.  In the case of Flex and the ArcGIS API for Flex, Flex is implementing the ArcGIS API for Flex in order to facilitate interaction between Flex and ArcGIS.  It lets you use and integrate ArcGIS Server resources (maps, locators, geoprocessing models) and Flex components (grids, trees, and charts).
Flash Builder IDE (Integrated Development Environment)
This is the software that allows you to program, debug, and compile SWF files.  Compared to Flash CS5 (which will also generate SWF files), Flash Builder is designed for programmers and is based on Eclipse, a popular IDE.  Graphic artists will still prefer to use Flash CS5, but for programming with the Flex API you will want to use Flash Builder.
You can download a trial version of Flash Builder 4 from http://www.adobe.com/go/try_flashbuilder
You can apply for an educational license (free!) at http://www.adobe.com/devnet-archive/flex/free/.  Otherwise it is $299 for commercial use.
ArcGIS API for Flex
Click on the Using samples (above the Mapping folder).  On that page click on the Getting Started link. 
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Creating an application using the ArcGIS AP for Flex
To begin working with the ArcGIS API for Flex, follow the steps below:

Download Wrto oo Run S8 pisplay SWF

API library application

1. Download and unzip the ArcGIS API for Flex ZIP file. Inside, you will find the ArcGIS AP for Flex library (.swc), a samples directory, and a
readme file.

Be sure to either store the .swc file in the libs folder in your project or specify the library path in Adobe Flash Builder. To specify the path in
Flash Builder:
a. Right-click the project and ciick "Properties”. Alternatively, on the file menu, go to "Project -> Properties”.
b. Click "Flex Build Path”.
c. Click the "Library Path” tab.
d. Click "Add SWC” button.
e. Browse to the SWC file you unzipped earler.
2. In your Flex environment, create an application by writing code to access the ArcGIS Server resources. You may also start by exploring the
samples. For instance, the following is the source code for accessing a tiled map:

<ouml version="1.0" encoding="use-8"2>
<s:Bpplication xmlns: x="hcop://ns-adobe. com/mml/2009"
"1ibrary://ns adobe.con/flex/spark”
‘hcop: / /s _eszi_com/2008/ags"
pageTivle="Example #17>

<esziMap>
<esri:ArcGISTiledMapServicelayer
url="hocp: //server aregisonline. com/AreGIS/rest/services/Horld Scress Map/MapServer” />
</esziMap>
</s:3pplicacion>

3. Compile the code to create your application.
For deployment tips, see Deploving vour application.

Copyright © 2008-2010 ESRI, Inc. Al rights
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Browsing the samples

Let’s dive in and look a few samples.  First though, here are a few things to be thinking about when we look through the samples:

· Extent.  When you launch the application, what area is shown on the map?  The world?  The United States?  A city or state?

· Basemap(s).  What is the reference layer(s)?  Is it imagery, topographic maps, a street map?

· Operational layers.  These could be thought of as your thematic layers, the layers that go on top of your basemap.

· Functionality  and tools.  What does the application do?  Can you click, hover, or otherwise interact with the features to get information?  Are there tools to help you interact with the map?
· Scale dependency.  How does layer symbology, detail, or visibility change as you zoom in or out?
the samples

1. Navigate to http://help.arcgis.com/en/webapi/flex/samples/index.html
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2. Expand the folder labeled Mapping, and click on the World Topographic Map sample.
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The World Topographic Map launches in the window to the right, defaulting to the Application tab.  Note that the map opens on an area in San Fransisco around the San Miguel Hills.  There’s a slider for zooming, a scalebar, and a logo.  Finally, if you zoom in an out, you’ll notice that the symbology changes, becoming more generalized when you zoom out, and more detailed as you zoom in.

3. Click the Source Code tab and have a quick look at TopographicMap.mxml.
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There really isn’t that much to the code to make this simple application.  Basically, we’ve got an application that has a map (which has some default elements – the zoom slider, scalebar and logo) with a layer or service in it, and we’ve got an extent defined (the San Fransisco extent).

4. Compare this first sample to the World Imagery Map, World Street Map, and Terrain with custom data samples.  How are they the same?  How are they different?  (Hint:  Think basemap and extent.)
a. The World Imagery Map opens up to Mt. Rainier in Washington.

b. The World Street Map opens to Buckingham Palace and surrounding grounds in London, England.

c. The Terrain basemap with custom data opens to a view of Europe.  There’s something extra in this map, though.  The basemap is different, but there are three layers or services in the application.  The Terrain, a reference layer, and in sandwiched between these layers is a thematic map of population.  (Note the order of these services in the code.  The terrain layer is first, then population, and finally the reference layer on last.  When you launch the application, though, the reference layer is on top!  Exactly the opposite of how they would appear if you put them into an ArcMap document).

Next we’re going to take one of these simple applications and modify it in Flash Builder by adding other services, and then adding a modicum of functionality.  Before we can do that we’re going to have to download the API.
Downloading the API
1. Follow the instructions on the How to download the Flex API page (sign in, accept license agreement, and download).

2. Save the zip file somewhere on your hard drive. 

3. Unzip the file to the same location.
4. Launch Flash Builder 4.
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5. To create a new new project, click File  > New > Flex Project
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6. In the New Flex Project dialog

a. Project name:  MyFirstFlexApp
b. Use the default location

c. Use the default SDK

d. Application server type: None/Other
e. Click Next
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7. Accept the default Compiled Flex Application location

a. Output folder:  bin-debug

b. Click Next.
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8. This page opens automatically to the Library path tab

a. Make sure the radio button next to MX + Spark is selected

b. Accept the default Framework linkage

c. Click the Add SWC… button, and navigate to the unzipped folder we downloaded earlier, and select agslib-2.2-2010-12-08.swc, and click OK

d. Click Finish
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9. Your Package Explorer on the left side of your view, now contains your new project called MyFirstFlexApp.  Inside that project are some other folders (src, Flex 4.0, Referenced Libraries, bin-debug, html-template, and libs).  For our purposes in this class, we will deal mainly with the src folder.  Notice that inside the src folder inside what’s called the “(default package)” is a file with the same name as your project, but with a .mxml file extension.  It has a green triangle or arrow indicating it is a Flex MXML application, and the blue ball means it is the project’s default main application.  
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10. Click on the green play button to Run the application.  Your default browser will open and it will be empty.  We haven’t added any code yet!

With the ArcGIS API for Flex download comes a over 100 samples, the same samples we browsed earlier.  This makes it easy to copy the code from an individual sample or to simply modify it directly.  

Modifying an existing sample

Let’s modify the Terrain with custom data sample.  

1. In Window Explorer, Navigate to the following folder in the ArcGIS API for Flex download folder
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2. Copy the file, TerrainBasemap.mxml into the src folder of you’re your project in Flash Builder.
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3. Double-click the TerrainBasemap.mxml application and it will open in a new tab next to MyFirstFlexApp.mxml

4. Compare the code in these two applications.  Note the following differences. 

a. xmlns

b. pageTitle

c. Comments

d. Extent

e. Map

f. Layers

5. Copy all the text from TerrainBasemap.mxml application and paste it into MyFirstFlexApp.mxml

6. Change the pageTitle:  Change everything in the quotes next to pageTitle

7. Optional:  Add comments.

a. Type out your comments in plain text

b. Highlight your comments

c. Click the Source menu, and go to Toggle Block Comment

8. Change the extent of your map.  A really handy tool that I use a lot is the Extent Helper.  

a. Go the following URL:  http://help.arcgis.com/en/webapps/flexviewer/index.html
b. Click on Concepts
c. Then click on the link for the Extent Helper on the left hand side of the page, toward the bottom of the list.

d. A map will load that you can use to zoom and pan around to your area of interest and then use the coordinates of the bounding box to plug in to your custom extent in your own application.

e. After changing the extent xmin, ymin, xmax and ymax properties, run the application by clicking on the green play (Run) button.

9. Add your own operational layers

a. Soil Survey layer – this one is from ArcGIS Online, and was compiled from a number of soils data sources

i. Replace the URL for the demographic data with this URL -  http://server.arcgisonline.com/ArcGIS/rest/services/Specialty/Soil_Survey_Map/MapServer
ii. Change the layer’s id property to soilSurvey
b. Geology layer – this layer was published from data available for download on the ISGS website

i. Duplicate the soilSurvey layer, and change the URL to the one written on the board

ii. Change the layer’s id property to surficialGeology
10. Run the application
Adding Functionality
In this section we’ll add a bit of functionality by adding a control bar with some buttons that will allow us to toggle layers on and off and how to return to our original extent.

1. Add a control bar to your application.  Place your cursor just above your opening <esri:Map tag and begin typing a < sign.  This will trigger code-hinting, a very handy feature of using an IDE that provides it.  Now type the first few letters of controlbar, and your options should narrow, then select  <s:controlBarContent> from the list.    Now type >, and the rest of the opening tag and the closing tag will be completed for you.
2. Add a label to the control bar

a. Place your cursor between the two control bar tags.  Use code hinting again to add the code <s:Label, but this time, instead of closing the tag with a >, close it with />.

b. Add a title for your application by setting the text property:  text = “My First Flex Map App”.
3. Add  buttons to your control bar.  

a. Use code hinting again to add the code <s:Button, but this time, and again, close it with />.
b. Assign values to the following properties

i. label = “Surficial Geology”

ii. click = “surficialGeology.visible = !surficialGeology.visible;”

c. Repeat step b for the remaining layers in your map.
d. Add a final button for returning to the initial extent of the map.

i. Label = “Zoom to initial extent”

ii. Click = “map.extent = initialExtent”
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ArcGIS Viewer for Flex
ESRI has published the ArcGIS Viewer for Flex to help you more easily deploy web applications.  This is a deployable package built on the Flex API that already includes a basic web application with a default set of controls that are easily configurable using .xml files.
Downloading the ArcGIS Viewer for Flex
To download the ArcGIS Viewer for Flex, you will need an ESRI Global account.  The zip file is available at
http://help.arcgis.com/en/webapps/flexviewer/ or http://www.isws.illinois.edu/ftp/gis/download/agsflex/flexviewer-2.2-src.zip.  If you are going to the ESRI web site, make sure to select “Download source code for Viewer.”  Do NOT unzip the file at this point.

Note: you may find some references online to the previous name of this project: Sample Flex Viewer.

Starting with the ArcGIS Viewer for Flex
1. Open Flash Builder 4.

2. Select File > Import Flex Project
3. Select the flexviewer-2.2-src.zip you downloaded earlier.

4. Assign a new project name (last folder name; such as FlexDemo). You should see it in the Package Explorer in the upper left of your Flash Builder app.
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5. Press the “Play” button (Run index) [image: image30.png]


 to see the application in a browser.  You will see the default settings of the Viewer for Flex.  The top row contains an icon, a title, a caption, and a set of tools.  The Find an Address tool is opened by default, and the ESRI Streets basemap is the default basemap (you can toggle to Aerial or Topo). [image: image31.png]W ArcGIS Viewer for Flex
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Customizing the Viewer for Flex interface
The Viewer for Flex settings are stored in .xml configuration files.  The master config file is referenced in the ViewerContainer.mxml file.  Let’s start making some changes to the default appearance:

1. Open the ViewerContainter.mxml file.

2. Change the DEFAULT_CONFIG_FILE to “config-mydemo.xml”
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3. Next, make a copy of config.xml (right click, copy, paste).  Give it the name from the previous step.
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4. Change the title and subtitle in the first block.  Change the colors if you want (colors are explained at http://help.arcgis.com/en/webapps/flexviewer/help/styling.htm)
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5. The Navigation UI elements are next.  You don’t need to change them, but just know they are here.

6. Let’s change the map extent to Illinois.  Use the Map Extent viewer to help http://help.arcgis.com/en/webapps/flexviewer/help/extenthelper/flexviewer_extenthelper.html
7. Add the USGS gages from our earlier exercise to our map.
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Notes: the label can be anything you want.  Unless you choose to build a tiled cache, ArcGIS will automatically serve map services as dynamic layers.  You can change the default visibility if you want.

8. Save changes to config-mydemo.xml
9. Switch to Firefox and open Tools > Options and look at the Advanced tab.  Click on “Clear Now” to clear the offline cache.  This will remove the cached copy of the previous config-mydata.xml
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10. Run the program again from Flash Builder.  You should be able to add in the USGS gages to your map.

Deploying application to web server

1. From Flash Builder, open Project > Export Release Build
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2. Stick with the defaults on this page and click Finish.
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3. Flash Builder will compile a SWF that is optimized for release (does not have debug capabilities) in the bin-release of our project folder.  Copy these into a folder in your web directory and you are finished.
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Configuring crossdomain.xml

From http://resources.esri.com/help/9.3/arcgisserver/apis/flex/help/index.html#references/using_crossdomain_xml.htm#:

“To access data from a different server than the one hosting your Flex application, the remote server needs to have a cross-domain file in the root directory. For security reasons, the Web browser cannot access data that resides outside the exact Web domain where the SWF file originated. However, Adobe Flash Player can load data across domains if permission is granted from the server. This is accomplished by including a small crossdomain.xml file on the remote server that permits Flash to connect to services on that server.”

The link above will provide you with a sample crossdomain.xml to use with ArcGIS Server.

More information

ESRI Development Center at UIUC

EDC web site: http://www.inrs.illinois.edu/edc/
EDC Facebook group (EDC@UIUC: GIS Training Program): http://www.facebook.com/home.php#/group.php?gid=123698680947&ref=ts
GIS help
ArcGIS Desktop 10 Help: http://help.arcgis.com/
ESRI KnowledgeBase and forums: http://support.esri.com/
ESRI Training: http://training.esri.com/gateway/index.cfm (Virtual Campus courses are freely available to University faculty, staff, and students through WebStore http://webstore.illinois.edu)
Flex 

ArcGIS API for Flex Resource Center  http://help.arcgis.com/en/webapi/flex/index.html
ArcGIS API for Flex forum: http://forums.arcgis.com/forums/18-ArcGIS-API-for-Flex
Flex Sample Viewer: http://help.arcgis.com/en/webapps/flexviewer/
Getting the software

For University-owned computers: ESRI ArcGIS is available as part of our site-license for University-owned computers.  For more information, visit the WebStore: http://webstore.illinois.edu/
For personal computers: A 60-day trial of ESRI ArcGIS can be requested at http://www.esri.com/software/arcgis/arcview/eval/evaluate.html
Getting Data

Illinois Geospatial Clearinghouse: http://www.isgs.illinois.edu/nsdihome/
National Atlas: http://nationalatlas.gov/
National Elevation Dataset: http://ned.usgs.gov/
National Hydrography Dataset: http://nhd.usgs.gov/
Aerial photography, soils, average temp/precip, watershed boundaries, and more: http://datagateway.nrcs.usda.gov/
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