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Introduction to ArcGIS 10.1 for Server 

Connecting to an ArcGIS Server 

View REST services in browser 
In your browser, go to http://sampleserver6.arcgisonline.com/ArcGIS/rest/services to see an example of 
the REST services. 

View ArcGIS services in ArcCatalog 
1. In ArcCatalog, go to GIS Servers > Add ArcGIS Server, and choose to Use GIS services and click 

Next. 

 

http://sampleserver6.arcgisonline.com/ArcGIS/rest/services
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2. Enter http://sampleserver6.arcgisonline.com/arcgis/services into the Server URL and click 
Finish.  You should be able to double-click the connection and browse the available services. 

 

 

Installing ArcGIS Server 10.1 (SP1) on Windows 7 
1. Navigate to the installation folder on your computer (instructors will have this information).  

Double-click ESRI.exe to launch the setup program. 
 

2. Click Run, if prompted. 

 

http://sampleserver6.arcgisonline.com/arcgis/services
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3. Next to the ArcGIS for Server item (the first unbolded item in the list), click on the word Setup.  
At this point you may be prompted for administrative credentials, enter them and then proceed. 

 
4. Click Next to continue 
5. Accept the license agreement and then click Next to continue.  
6. Notice that program will be installed in the 64-bit Program Files directory (C:\Program 

Files\ArcGIS\Server\).  Click Next to continue.  
7. Accept the default Python Folder for installation. 
8. The arcgis account runs the ArcGIS Server Service, it can be a local or domain account and does 

not need administrative privileges.  By default the account is a local account called arcgis, and 
will be created for you.  It will be given the necessary permissions to run ArcGIS Server Services.  
File permissions on data files and folders on the server must be granted manually after 
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installation.  

 
9. Do not export configuration file. 

 
10. Click Install.  Installation time takes approximately 5 minutes (for reference, that’s on a desktop 

machine running 64-bit Windows 7 with 8GB of RAM and a 3.00 GHz, quad core).   

 

Software Authorization 
The software authorization wizard should automatically launch.  This procedure will authorize the 
ArcGIS Server software with Esri so that it functions properly. 

1. In the Software Authorization Wizard, under Authorization Options, choose “I have installed 
my software and need to authorize it”. Click Next. 
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2. Choose “I have received an authorization file from Esri and am now ready to finish the 
authorization process”.  Browse to the course folder and select the file named 
ArcGISforServerAdvancedEnterprise_server.prvc.  Click Next. 

3. Choose “Authorize with Esri now using the Internet”. Click Next. 
4. Use the default information supplied by the .prvc file.  Click Next. 

 
5. Select appropriate values for Your Organization, Your Industry, and Yourself.  Click Next. 

 
6. The authorization number should be already entered for you as it was included in the 

authorization file.  Click Next through the dialogs, and do not Evaluate Software Extensions. 
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7. Wait while the software is being authorized.  

 

Creating a site 
1. Open http://localhost:6080/arcgis/manager.  On your first site, you will be asked to Create New 

Site or Join Existing Site.  Click Create New Site. 

 
2. Create a Primary Site Administrator Account.  This account is required by ArcGIS Server to login 

to Manager, setup the site, and setup security.  It is NOT the arcgis server account, NOT an OS 
account; it is stored by ArcGIS Server and controls access to ArcGIS Server ONLY!!  Note:  You 
can change this users password later by logging into ArcGIS Server Manager, and going to 

http://localhost:6080/arcgis/manager
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Security > Settings and clicking the Edit (pencil) icon next to Primary Site Administrator Account. 

 
3. Specify location for Root Server Directory and Configuration Store.  In this lab, we’ll stick to the 

default locations on the C:\ drive. 
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4. Click Finish to complete installation.  This may take a few minutes. 

Post-installation configuration 

ArcGIS Server system folders 
Now you will give the appropriate permissions to the arcgis server account for the arcgisserver system 
folders.  They were created in the setup process, but the arcgis account on the local system needs to be 
manually configured. 

1. Navigate to the arcgisserver folder (C:\arcgisserver).  Right-click on the folder and choose 
Properties… 

2. On the Security tab, click Edit. 
3. In the Permissions dialog, click Add and search for the arcgis user (or whatever was specified as 

the ArcGIS System Account in the setup). 
4. Give this user Full control over this folder.  Click OK to exit dialogs.  

 

 

Data Store configuration 
Follow these steps to copy the course data and set it up so ArcGIS Server can access and display this 
data. 
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1. In Windows Explorer, copy EDC_Courses to the C:\ drive. 
2. Right-click folder, and on Security tab set permissions so that ArcGIS System account has read 

privileges (similar process as the arcgisserver folder 
previously) 

3. Login to ArcGIS Manager 
(http://localhost:6080/arcgis/manager/) 

4. Click on Site, then Data Store. 
5. Click Register Folder and enter the following data, 

then click Create: 
• Name: EDC_Courses (can be any text of your 

choosing) 
• Publisher Folder Path: C:\EDC_Courses (the 

directory to publish) 
• Publisher Folder Hostname: your computer 

hostname (you can find this by pressing WinKEY+Pause/Break) 
• Same as publisher folder path: checked 

6. Click the Validate All button to check that your folder is accessible to ArcGIS Server. 

Firewall 
In a production setting, you may need to open up firewall ports.  Common ports are 4000 to 4004, 6080, 
and 6443.  You can view ports in use at http://localhost:6080/arcgis/admin/machines (click on machine 
name and then expand Ports).  

Administrative connections to ArcGIS Server 
There are three main interfaces for managing ArcGIS Server: 

Manager (web): http://localhost:6080/arcgis/manager.  This is the web interface you can use to manage 
your server from any accessible web browser. 

Manager (ArcCatalog): A convenient way to administer ArcGIS Server with ArcCatalog.  To create an 
administrative connection: 

• In ArcCatalog go to GIS Servers > Add ArcGIS Server 
• Choose Administer GIS server 

http://localhost:6080/arcgis/manager/
http://localhost:6080/arcgis/admin/machines
http://localhost:6080/arcgis/manager
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• Enter the following: 

 

REST Admin (web): http://localhost:6080/arcgis/admin/.  This is the admin interface through the REST 
endpoint.  It is recommended to use Manager when possible, but some advanced settings and 
diagnostics can only be accessed through this interface. 

Publishing Services with ArcGIS 10.1 for Server 
In this exercise, you will: 

• Prepare a map for publishing. 
• Edit your service’s Item Description. 
• Analyze the map, and correct any errors. 
• Publish the service. 

You will take the following map document depicting surficial geology in Illinois and make it available as a 
web service so that it can be consumed on a client computer using desktop GIS software, or a web 
application.  Examples include ArcMap, ArcGIS.com, or a custom application configured or programmed 
using the ArcGIS API for JavaScript.  

Process Steps 
1. In ArcMap, open the Surficial_Geology_24K.mxd located in your C:\EDC_Courses folder, and 

take a couple of minutes to look over the content of the map.  Take special note of the 
following: 

a. File > Map Document Properties… 

http://localhost:6080/arcgis/admin/
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b. View > Data Frame Properties… 
c. Layer Properties for each layer 

i. General tab – Description, Credits, and Scale Range 
ii. Labels tab – Are there labels? 

d. Zoom in and out to see when the layers with Scale Ranges set turn on or turn off. 

 
2. Finally, right-click on the Counties layer and choose Zoom to Layer.  
3. From the File menu, chose Share As > Service…

 
4. In the Share as Service dialog, choose Publish a service, and click Next.  
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5. In the Publish a Service dialog, click on the  and make a connection to your ArcGIS Server. 
Alternatively, you can choose the Administrative connection previously created. 

6. In the General dialog box, choose Publish GIS services.  Click Next. 
7. Enter your Server URL, and supply your User Name and Password.  Click Finish. 

 
8. You will be returned to the Publish a Service wizard, where you can accept the default Service 

name, and click Next.  

 
9. Select the Create new folder radio button, and name the new folder Geology.  Click Continue. 
10. You are now in the Service Editor.  Set the properties that you want for your map service. Here, 

you can choose what users can do with your service and take fine-grained control of how the 
server will expose your service. For details on how to manually set map service properties, see 
the topic Setting map service properties.  For information on how to best configure your service 
for deployment, see the help topic Tuning and configuring services. 

11. Click on the Item Description tab.  This information should look familiar because the only 
element that is not extracted from the Map Document Properties is the Access and Use 
Constraints. 

http://resources.arcgis.com/en/help/main/10.1/0154/0154000003p1000000.htm
http://resources.arcgis.com/en/help/main/10.1/0154/015400000343000000.htm
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12.  Input the following text in the Access and Use Constraints box: 

“This data compilation is intended to provide an overview of the geology of the map area. The 
data do not replace the need for detailed site-specific studies. The information is not appropriate 
for, and is not to be used as, a geodetic, legal, or engineering base. The information has no legal 
basis in the definition of boundaries or property lines and is not intended as a substitute for 
surveyed locations such as can be determined by a registered Public Land Surveyor.” 

13. Click the Analyze button and review the Errors, Warnings, and Messages.  Only Errors  
absolutely have to be fixed.  Warnings and Messages should be reviewed and fixed to improve 
performance or appearance. 
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14. Optionally, click Preview to see what your map will look like on the web. 
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15. Finally, click Publish, and wait while the service is published to the server.  

 

 

Consuming Services Using the ArcGIS.com 

Demonstration by instructor.   

Consuming Services Using the ArcGIS API for JavaScript 

Explore a Sample 
1. Navigate to the ArcGIS API for JavaScript developer site:  

http://developers.arcgis.com/en/javascript/ 
2. Click on Samples in the top navigation bar. 
3. Expand the Query Task group of samples, and click on Query and immediately open info 

window. 
4. Click on the View live sample link just under the sample title. 
5. By default, users can choose the mouse, keyboard, and sliders for panning and zooming a map, 

depending on what is enabled in the HTML page. By default, users can do the following: 
• Drag the mouse to pan 
• Mouse Scroll Forward to zoom in 
• Mouse Scroll Backward to zoom out 
• SHIFT + Drag the mouse to zoom in 
• SHIFT + CTRL + Drag the mouse to zoom out 
• SHIFT + Click to recenter 
• Double Click to Center and Zoom in 
• SHIFT + Double Click to Center and Zoom in 

http://developers.arcgis.com/en/javascript/
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• Use arrow keys to pan 
• Use + key to zoom in a level 
• Use - key to zoom out a level 

6. Click on one of the oil fields and an Info window will appear with information about the polygon 
you clicked. 

Customize a Sample 
1. Now let’s customize this sample.  Close the live sample, and return to the sample launch page. 
2. Copy all of the code text for the sample to the clipboard and launch the ArcGIS API for 

JavaScript Sandbox using the following URL:  
http://help.arcgis.com/en/webapi/javascript/arcgis/sandbox/sandbox.html?sample=map_creat
e.  You can also get to the Sandbox from any location of the JavaScript API site by clicking on 
Tutorials > Build your first application, and then clicking on the blue link in the main page. 

 
3. Delete all of the code from the left side of the Sandbox under Source:, and then paste in the 

sample code. 
4. Click Run. 

http://help.arcgis.com/en/webapi/javascript/arcgis/sandbox/sandbox.html?sample=map_create
http://help.arcgis.com/en/webapi/javascript/arcgis/sandbox/sandbox.html?sample=map_create
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5. Now you should have the same Kansas petroleum fields sample running in the sandbox, and it 
should function just as it did before. 

 
6. Now alter the code so that it references a different basemap, our map service, and then edit the 

lines of code to query our map and show the information from the query in the Info window. 
a. Delete startExtent 

i. Go to line 23 of the code. 
ii. Delete the entire line of code that starts with var startExtent…  This line is not 

necessary for our purposes, and is for a location in Kansas.   
iii. Click Run again, just to make sure that nothing broke. 

b. Edit the basemap 
i. Go to line 24.   

ii. Change the satellite to one of the following:  topo, gray, or street. 
iii. You can click Run here again, too, to view the new basemap. 

c. Edit the map center 
i. Go to line 25. 

ii. Replace the coordinates with the following [-88.933, 37.732] 
iii. If you click Run now, the map will be centered on Marion, Illinois. 

d. Edit the map zoom 
i. Go to line 26. 

ii. Change the zoom level from 8 to 13. 
iii. If you click Run now, the map will be centered on Marion, Illinois. 
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e. Edit the ArcGISDynamicServiceLayer 
i. Go to line 30. 

ii. Delete the service URL that’s inside the quotes and parentheses with the service 
we created in the last exercise. 
http://localhost:6080/arcgis/rest/services/Geology/Surficial_Geology_24K/M

apServer 
iii. Click Run.   
iv. Now, instead of looking at the Petroleum Fields of Kansas, we’re looking at the 

Surficial Geology of Illinois.  Also notice that our while our geology service is 
visible, we can’t see through the polygons to the basemap service below. 

f. Edit the map service opacity 
i. Go back to line 30. 

ii. Position your cursor after map service URL, just after the end quote, but before 
the closing parenthesis. 

iii. Type:  , {opacity: "0.75"} 
iv. Click Run. 

g. Edit the QueryTask URL 
i. Go to line 40. 

ii. Replace the QueryTask URL with the Surficial Geology map service, but this 
time, add the index number of the Geologic Unit Areas layer to the end of the 
URL.  It is this layer that will be queried.  (Hint:  Use your REST services directory 
to drill down into the layer endpoint.) 

iii. Click Run.  Nothing happens.  Why? 
h. Edit the Query outFields 

i. Go to line 49. 
ii. Instead of specifying fields to be returned from the query, get all off the fields 

by replacing the list of field names with ["*"]. 
iii. Click Run.  

  
iv. While the geometry of the Geologic Unit Area is being returned when the user 

clicks on a polygon, we are not getting the attributes.   
i. Edit the infoWindow title and content 

i. Go to lines 81-85 and completely replace them with the following code: 

var title = attr.GUName; 
          var content = "<b>Unit Abbreviation:  </b>" + attr.GUAbbrev 
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                  + "<br /><b>Age:  </b>" + attr.GUAge 
                  + "<br /><b>Material Description:  </b>" + attr.GUMatDesc 

+ "<br /><b>Interpretation:  </b>" + attr.GUInterp; 

j. Click Run. 
k. Now when the user clicks on a polygon, they should see a fully populated infoWindow 

with attribute information from the Geologic Unit Polygons. 

 

Securing Services with ArcGIS for Server 10.1 
Exercise objectives 

In this exercise, you will: 

• Create users. 
• Create a role. 
• Secure the service, allowing access to a role. 
• Access the service from various client applications. 

Process Steps 
1. Login to ArcGIS Server Manager (http://localhost:6080/arcgis/manager/) using your Primary 

Site Administrator (PSA) credentials. 
2. Click Security (on the gray bar), and then Users (on the blue bar). 

 
3. Create users 

http://localhost:6080/arcgis/manager/
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a. Click the New User button.   
b. In the New User dialog, enter geouser1 as the Username, and then supply a password.   

 
c. Click the Create button. 
d. Repeat the steps above to create two more users.  Call them geouser2 and basicuser.   
e. When done, the screen should be as pictured below. 

 

4. Create a role 
a. Click on Roles. 
b. Click the New Role button. 
c. In the New Role dialog, enter geouser1 as the Username, In the New Role dialog, give 

the role a name, description, and add users by clicking on the  icon next to their 
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names.   

 
d. Click the Create button. 

5. Secure a service. 
a. Click on Services (on top gray bar), then under Folders, click on the Geology folder.  The 

Surficial_Geology_24K map service is shown in the service gallery.

 
b. Click on the         icon.  (All services are by default public.)  Click on the Private, available 

only to selected users radio button, and then click the  button to add the GeoUsers 
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role to the list of Allowed roles.  

 
c. Click Save.   
d. Note:  While GeoUsers is the only role that has had permission explicitly given to it, any 

users in a Publisher or Administrator role will also be able to access to the service. 
e. Sign out of ArcGIS Server Manager, and close your browser. 

6. Test User Access Scenarios. 
a. ArcGIS REST Services Directory 

i. Open a browser, and navigate to your service’s REST endpoint.   
http://localhost:6080/arcgis/rest/services/Geology/Surficial_Geology_24K/Map
Server 

ii. When a user tried to access a secured service using the REST endpoint of the 
service or one of its layers, the following Login page will appear, prompting 
them to enter their credentials.  

http://localhost:6080/arcgis/rest/services/Geology/Surficial_Geology_24K/MapServer
http://localhost:6080/arcgis/rest/services/Geology/Surficial_Geology_24K/MapServer
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b. ArcGIS.com 

i. When a user adds the service to the map by clicking Add > Add Layer from Web, 
they will be prompted to sign in.   

    
ii. After successfully signing in, the map should be added to the map. 

c. ArcGIS API for JavaScript – Identity Manager widget. 
i. Return to your JavaScript Sandbox code from the last exercise.  

ii. Find the list of dojo.require statements, and add the following statement to the 
code (hint:  it’ll be somewhere around line 18): 

dojo.require("esri.IdentityManager"); 
iii. Click Run. 
iv. Enter you credentials when the Sign in dialog is shown 

http://www.arcgis.com/home/webmap/viewer.html?useExisting=1
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v. Click OK 

vi. Upon successfully signing in, your layer will be added to the map. 

Information 
This course material was developed for use by the Esri Development Center at the University of Illinois.  
Last updated April 2, 2013. 

Instructors 
Melony Barrett 

Geospatial Application Developer, Illinois State Geological Survey.  mebarret@illinois.edu 

Phil Graff 
GIS Coordinator, Illinois State Water Survey.  pgraff@illinois.edu 
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